Wrong error response returned when an OEM being uploaded is already present in our system and no force overwrite was requested
Resolved·Degraded performance

The fix was deployed successfully.

Fri, Nov 21, 2025, 09:06 PM
(2 weeks ago)
·
Affected components
Space objects APIs
Updates

Resolved

The fix was deployed successfully.

Fri, Nov 21, 2025, 09:06 PM

Identified

Due to a recent refactor in how errors are handled internally, a regression was introduced in the error response returned when an OEM file uploaded is already present in our system. Due to this, instead of returning a 409 conflict HTTP response, the system incorrectly returns a 500 internal server error. The issue has already been identified and fixed, and we're in the process of deploying it.

Fri, Nov 21, 2025, 08:44 PM(22 minutes earlier)
Powered by